Navigation

Which Android devices are supported?

Mobilizr supports all Android operating systems from Android 4.1 and above. To use Mobilizr, you require either Android 4.1, 4.2, 4.3, 4.4, 5.0, 5.1, 6.0 or 7.0